Excel: Wie kann man herausfinden, ob in einem Text Zahlen zu finden sind?

Aufgabe:
Ich wollte wissen, ob die Zelle A1 mindestens eine Ziffer enthält.
Sollte dies nicht der Fall sein, so soll in der Zelle B1 der Text “enthält keine Ziffer” erscheinen.

Lösungsvorschlag:
=WENN(ODER(WENN(ISTFEHLER(SUCHEN(”1″;A2));FALSCH;WAHR);WENN(ISTFEHLER(SUCHEN(”2″;A2));FALSCH;WAHR);WENN(ISTFEHLER(SUCHEN(”3″;A2));FALSCH;WAHR);WENN(ISTFEHLER(SUCHEN(”4″;A2));FALSCH;WAHR);WENN(ISTFEHLER(SUCHEN(”5″;A2));FALSCH;WAHR);WENN(ISTFEHLER(SUCHEN(”6″;A2));FALSCH;WAHR);WENN(ISTFEHLER(SUCHEN(”7″;A2));FALSCH;WAHR);WENN(ISTFEHLER(SUCHEN(”8″;A2));FALSCH;WAHR);WENN(ISTFEHLER(SUCHEN(”9″;A2));FALSCH;WAHR);WENN(ISTFEHLER(SUCHEN(”0″;A2));FALSCH;WAHR));” “;”enthält keine Ziffer”)

Ihnen hat dieser Artikel gefallen und Sie wollen mir unbedingt etwas Gutes tun? Dann klicken Sie einfach jeweils einmal auf die folgenden Symbole. Fertig! (Keine Bange. Sie kaufen damit weder eine Waschmaschine noch treten Sie irgendeiner Sekte bei. Sie helfen mir nur dabei ein besseres PageRanking zu erhalten. Das sagt man jedenfalls. Ob es stimmt? Keine Ahnung.) Danke! ;-)
Diese Icons verlinken auf Bookmark Dienste bei denen Nutzer neue Inhalte finden und mit anderen teilen können.
MisterWong Y!GG Webnews Digg del.icio.us StumbleUpon Reddit Technorati YahooMyWeb
erstellt am 18. Mai 2011 11:37    abgelegt unter: Excel

nach oben

2 Kommentare zu “Excel: Wie kann man herausfinden, ob in einem Text Zahlen zu finden sind?”

  1. Reimund Acker:

    In OpenOffice Calc geht’s unter Verwendung des regulären Ausdrucks [0-9]etwas einfacher:

    =WENN(ISTFEHLER(SUCHEN(”[0-9]“;A2));”enthält keine Ziffer”;”")

    Kann Excel eigentlich inzwischen reguläre Ausdücke?

    Beste Grüße
    Reimund Acker

  2. Elke Burmester:

    Hallo Herr Acker,

    vielen Dank für Ihren Hinweis / Ihre Funktion, die ich auch in Excel testen werde, denn eigentlich sollte Excel mit regulären Ausdrücke umgehen können. Vielleicht habe ich ja auch einen Fehler gemacht?
    Sollte ich neue Erkenntnisse haben, werde ich Sie (alle) hier an dieser Stelle davon in Kenntnis setzen.

    MfG
    Elke Burmester

    Update:
    OpenOffice Calc scheint da schon weiter zu sein. Denn lt. vieler Excel-Anwender kennt Excel noch keine regulären Ausdrücke, was mich ehrlich gestanden sehr wundert, aber…
    Vielleicht ein Grund mehr auf die kostenlose Software OpenOffice umzusteigen, die man hier herunterladen kann.

Kommentar erstellen:
Bevor Sie einen Kommentar schreiben können, müssen Sie registriert und angemeldet sein. Bitte klicken Sie hier.