Archiv Mai 2011

Excel: Wie kann man herausfinden, ob in einem Text Zahlen zu finden sind?

Aufgabe:
Ich wollte wissen, ob die Zelle A1 mindestens eine Ziffer enthält.
Sollte dies nicht der Fall sein, so soll in der Zelle B1 der Text “enthält keine Ziffer” erscheinen.
Lösungsvorschlag:
=WENN(ODER(WENN(ISTFEHLER(SUCHEN(”1″;A2));FALSCH;WAHR);WENN(ISTFEHLER(SUCHEN(”2″;A2));FALSCH;WAHR);WENN(ISTFEHLER(SUCHEN(”3″;A2));FALSCH;WAHR);WENN(ISTFEHLER(SUCHEN(”4″;A2));FALSCH;WAHR);WENN(ISTFEHLER(SUCHEN(”5″;A2));FALSCH;WAHR);WENN(ISTFEHLER(SUCHEN(”6″;A2));FALSCH;WAHR);WENN(ISTFEHLER(SUCHEN(”7″;A2));FALSCH;WAHR);WENN(ISTFEHLER(SUCHEN(”8″;A2));FALSCH;WAHR);WENN(ISTFEHLER(SUCHEN(”9″;A2));FALSCH;WAHR);WENN(ISTFEHLER(SUCHEN(”0″;A2));FALSCH;WAHR));” “;”enthält keine Ziffer”)

erstellt am 18. Mai 2011 11:37    abgelegt unter: Excel

2 Kommentare